aboutsummaryrefslogtreecommitdiffstats
path: root/libtransport/src/hicn/transport/CMakeLists.txt
diff options
context:
space:
mode:
authorAngelo Mantellini <manangel@cisco.com>2019-02-10 12:49:21 +0100
committerAngelo Mantellini <manangel@cisco.com>2019-02-11 14:32:16 +0100
commit4c8876424cca41c8ce8ce67c1c0a394932cbdd58 (patch)
tree03ce5e673a9409b35ba7abf65e1740309ef44653 /libtransport/src/hicn/transport/CMakeLists.txt
parent731e1188262be87d962f5694022fc74928d889b0 (diff)
[HICN-46] Remove warnings libtransport on windows
Change-Id: I09456770dcbca979491cdcadb310eab95a0dea17 Signed-off-by: Angelo Mantellini <manangel@cisco.com>
Diffstat (limited to 'libtransport/src/hicn/transport/CMakeLists.txt')
-rw-r--r--libtransport/src/hicn/transport/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/libtransport/src/hicn/transport/CMakeLists.txt b/libtransport/src/hicn/transport/CMakeLists.txt
index 92330c10b..c0481ad6f 100644
--- a/libtransport/src/hicn/transport/CMakeLists.txt
+++ b/libtransport/src/hicn/transport/CMakeLists.txt
@@ -35,7 +35,15 @@ list(APPEND LIBTRANSPORT_INCLUDE_DIRS
${CMAKE_CURRENT_BINARY_DIR}/../..
)
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
+
+if (NOT WIN32)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
+else ()
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4200")
+ if (CMAKE_BUILD_TYPE EQUAL "RELEASE")
+ set(CMAKE_SHARED_LINKER_FLAGS "/NODEFAULTLIB:\"MSVCRTD\"" )
+ endif ()
+endif ()
if (ANDROID_API)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc++ -isystem -lm")
endif()