aboutsummaryrefslogtreecommitdiffstats
path: root/libtransport/src/hicn/transport/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-07-18 10:13:49 +0200
committerMauro Sardara <msardara@cisco.com>2019-07-18 10:45:08 +0200
commit64442da40c3e390649d42e3e97a74986bba27afd (patch)
tree35e265c654c01822bc398ed16b8108509d9a28c0 /libtransport/src/hicn/transport/CMakeLists.txt
parent87cd4b4d22a08f1b56cd067770a29bcb05ebb845 (diff)
[HICN-248] Install libraries under correct folder (lib/x86_64-linux-gnu on ubuntu/debian and lib64 on centos)
Change-Id: I9c8fc206f2f93b9eae1060387ab6d0833da80124 Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'libtransport/src/hicn/transport/CMakeLists.txt')
-rw-r--r--libtransport/src/hicn/transport/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/libtransport/src/hicn/transport/CMakeLists.txt b/libtransport/src/hicn/transport/CMakeLists.txt
index b6be3f77a..3b5e9a15f 100644
--- a/libtransport/src/hicn/transport/CMakeLists.txt
+++ b/libtransport/src/hicn/transport/CMakeLists.txt
@@ -13,6 +13,8 @@
cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
+include(GNUInstallDirs)
+
set(ASIO_STANDALONE 1)
add_subdirectory(core)
@@ -26,7 +28,7 @@ add_subdirectory(utils)
configure_file("config.h.in" "config.h" @ONLY)
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/config.h
- DESTINATION include/hicn/transport
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/hicn/transport
COMPONENT lib${LIBTRANSPORT}-dev
)