aboutsummaryrefslogtreecommitdiffstats
path: root/libtransport/src/hicn/transport/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-10-22 12:01:54 +0200
committerMauro Sardara <msardara@cisco.com>2019-10-22 12:01:54 +0200
commit7429211aee3daa4227e10d2541920c0dea785191 (patch)
tree21dc0f5a1075d33dc42e34d880f086589253aff4 /libtransport/src/hicn/transport/CMakeLists.txt
parent49b9891dc32ea1fbd0af4711a200b425c7482da0 (diff)
[HICN-346] Add version of the transport library in the config.h header file.
Change-Id: I1ce0b705db98f4042470a7b80b422720ba03c0f6 Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'libtransport/src/hicn/transport/CMakeLists.txt')
-rw-r--r--libtransport/src/hicn/transport/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libtransport/src/hicn/transport/CMakeLists.txt b/libtransport/src/hicn/transport/CMakeLists.txt
index 6e0ae5b88..22acdcb7f 100644
--- a/libtransport/src/hicn/transport/CMakeLists.txt
+++ b/libtransport/src/hicn/transport/CMakeLists.txt
@@ -25,6 +25,8 @@ add_subdirectory(portability)
add_subdirectory(protocols)
add_subdirectory(utils)
+include(Packager)
+extract_version()
configure_file("config.h.in" "config.h" @ONLY)
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/config.h