aboutsummaryrefslogtreecommitdiffstats
path: root/libtransport/src/hicn/transport/CMakeLists.txt
diff options
context:
space:
mode:
authormichele papalini <micpapal@cisco.com>2019-02-18 16:12:36 +0100
committermichele papalini <micpapal@cisco.com>2019-02-18 16:12:36 +0100
commitdd81185294bdda4203c747a9ce5c19a63c55dbd4 (patch)
treec6ba42069d36b526002592e92bd37d8c41d49cee /libtransport/src/hicn/transport/CMakeLists.txt
parent63140cf46b43824d77206402cef13f01c2b9cdde (diff)
[HICN-69] add compiler definitions for programs using hicn
Change-Id: If20c1e487ca4d9c00ffeebe09f31b475b354e293 Signed-off-by: michele papalini <micpapal@cisco.com>
Diffstat (limited to 'libtransport/src/hicn/transport/CMakeLists.txt')
-rw-r--r--libtransport/src/hicn/transport/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/libtransport/src/hicn/transport/CMakeLists.txt b/libtransport/src/hicn/transport/CMakeLists.txt
index c0481ad6f..e73a3407a 100644
--- a/libtransport/src/hicn/transport/CMakeLists.txt
+++ b/libtransport/src/hicn/transport/CMakeLists.txt
@@ -13,6 +13,8 @@
cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
+set(ASIO_STANDALONE 1)
+
configure_file("config.h.in" "config.h" @ONLY)
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/config.h
@@ -28,7 +30,7 @@ add_subdirectory(portability)
add_subdirectory(protocols)
add_subdirectory(utils)
-set (COMPILER_DEFINITIONS "-DASIO_STANDALONE")
+set (COMPILER_DEFINITIONS "")
list(APPEND LIBTRANSPORT_INCLUDE_DIRS
${CMAKE_CURRENT_SOURCE_DIR}/../..
@@ -63,4 +65,4 @@ build_library(${LIBTRANSPORT}
if (${COMPILE_TESTS})
add_subdirectory(core/test)
add_subdirectory(transport/test)
-endif() \ No newline at end of file
+endif()