aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0001a0a45..2ea6de33d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,9 @@ option(BUILD_APPS "Build the hicn apps" OFF)
option(BUILD_CTRL "Build the hicn control tools" ON)
option(BUILD_HICNPLUGIN "Build the hicn vpp plugin" OFF)
option(BUILD_SYSREPOPLUGIN "Build the sysrepo plugin" OFF)
-option(BUILD_EXTRAS "Build external projects." OFF)
+option(BUILD_EXTRAS "Build external projects" OFF)
+option(DISABLE_EXECUTABLES "Disable executables" OFF)
+option(DISABLE_SHARED_LIBRARIES "Disable shared libraries" OFF)
if ((BUILD_APPS OR BUILD_UTILS) AND NOT BUILD_LIBTRANSPORT)
message(STATUS "Libhicntransport required. Enabled by default.")
@@ -84,7 +86,7 @@ foreach (opt ${dir_options})
endforeach()
if (NOT WIN32)
- add_compile_options(-Wall -Werror)
+ add_compile_options(-Wall -Werror -Wno-shorten-64-to-32)
endif ()
message(STATUS "Building the following subprojects: ${subdirs}")