aboutsummaryrefslogtreecommitdiffstats
path: root/apps/hiperf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'apps/hiperf/CMakeLists.txt')
-rw-r--r--apps/hiperf/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/apps/hiperf/CMakeLists.txt b/apps/hiperf/CMakeLists.txt
new file mode 100644
index 000000000..564525e67
--- /dev/null
+++ b/apps/hiperf/CMakeLists.txt
@@ -0,0 +1,44 @@
+# Copyright (c) 2017-2019 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+if (NOT DISABLE_EXECUTABLES)
+ list(APPEND HIPERF_SRC
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/client.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/main.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/server.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/src/forwarder_interface.cc
+ )
+
+ list (APPEND HIPERF_LIBRARIES
+ ${LIBTRANSPORT_LIBRARIES}
+ ${LIBHICNCTRL_LIBRARIES}
+ ${LIBHICN_LIBRARIES}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${LIBCONFIG_CPP_LIBRARIES}
+ ${WSOCK32_LIBRARY}
+ ${WS2_32_LIBRARY}
+ )
+
+ build_executable(hiperf
+ SOURCES ${HIPERF_SRC}
+ LINK_LIBRARIES ${HIPERF_LIBRARIES}
+ INCLUDE_DIRS
+ ${CMAKE_CURRENT_SOURCE_DIR}/src
+ ${LIBTRANSPORT_INCLUDE_DIRS}
+ ${LIBHICNCTRL_INCLUDE_DIRS}
+ ${LIBCONFIG_CPP_INCLUDE_DIRS}
+ DEPENDS ${DEPENDENCIES}
+ COMPONENT ${HICN_APPS}
+ LINK_FLAGS ${LINK_FLAGS}
+ )
+endif() \ No newline at end of file