aboutsummaryrefslogtreecommitdiffstats
path: root/apps/http-proxy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'apps/http-proxy/CMakeLists.txt')
-rw-r--r--apps/http-proxy/CMakeLists.txt18
1 files changed, 10 insertions, 8 deletions
diff --git a/apps/http-proxy/CMakeLists.txt b/apps/http-proxy/CMakeLists.txt
index cc47e4b6f..94bf895c1 100644
--- a/apps/http-proxy/CMakeLists.txt
+++ b/apps/http-proxy/CMakeLists.txt
@@ -58,11 +58,13 @@ build_library(${LIBHTTP_PROXY}
LINK_FLAGS ${LINK_FLAGS}
)
-build_executable(${HTTP_PROXY}
- SOURCES ${APP_SOURCE_FILES}
- LINK_LIBRARIES ${LIBHTTP_PROXY_STATIC}
- DEPENDS ${LIBHTTP_PROXY_STATIC}
- COMPONENT ${HICN_APPS}
- DEFINITIONS ${COMPILER_DEFINITIONS}
- LINK_FLAGS ${LINK_FLAGS}
-)
+if (NOT DISABLE_EXECUTABLES)
+ build_executable(${HTTP_PROXY}
+ SOURCES ${APP_SOURCE_FILES}
+ LINK_LIBRARIES ${LIBHTTP_PROXY_STATIC}
+ DEPENDS ${LIBHTTP_PROXY_STATIC}
+ COMPONENT ${HICN_APPS}
+ DEFINITIONS ${COMPILER_DEFINITIONS}
+ LINK_FLAGS ${LINK_FLAGS}
+ )
+endif ()