aboutsummaryrefslogtreecommitdiffstats
path: root/apps/http-server/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'apps/http-server/CMakeLists.txt')
-rw-r--r--apps/http-server/CMakeLists.txt16
1 files changed, 7 insertions, 9 deletions
diff --git a/apps/http-server/CMakeLists.txt b/apps/http-server/CMakeLists.txt
index 94aa9d43a..bedb6afc1 100644
--- a/apps/http-server/CMakeLists.txt
+++ b/apps/http-server/CMakeLists.txt
@@ -58,27 +58,25 @@ set(APP_SOURCE_FILES
)
include_directories(
- ${CMAKE_BINARY_DIR}/apps/http-server
http-server
http-client
)
-build_library(hicn-httpserver
+set(LIBHTTP_SERVER hicnhttpserver)
+
+build_library(${LIBHTTP_SERVER}
STATIC
- SOURCES ${LIB_SOURCE_FILES} ${LIB_SERVER_HEADER_FILES} ${LIB_CLIENT_HEADER_FILES}
- INSTALL_HEADERS ${HEADER_FILES}
+ SOURCES ${LIB_SOURCE_FILES}
LINK_LIBRARIES ${LIBRARIES}
DEPENDS ${DEPENDENCIES}
- COMPONENT lib${LIBTRANSPORT}
INCLUDE_DIRS ${LIBTRANSPORT_INCLUDE_DIRS}
- INSTALL_ROOT_DIR hicn/transport
DEFINITIONS ${COMPILER_DEFINITIONS}
)
-build_executable(hicn-http-server
+build_executable(${HTTP_SERVER}
SOURCES ${APP_SOURCE_FILES}
- LINK_LIBRARIES hicn-httpserver ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
- DEPENDS hicn-httpserver
+ LINK_LIBRARIES ${LIBHTTP_SERVER} ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
+ DEPENDS ${LIBHTTP_SERVER}
COMPONENT ${HICN_APPS}
DEFINITIONS ${COMPILER_DEFINITIONS}
)