aboutsummaryrefslogtreecommitdiffstats
path: root/ctrl/facemgr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ctrl/facemgr/CMakeLists.txt')
-rw-r--r--ctrl/facemgr/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/ctrl/facemgr/CMakeLists.txt b/ctrl/facemgr/CMakeLists.txt
index 377773c2d..a560be36a 100644
--- a/ctrl/facemgr/CMakeLists.txt
+++ b/ctrl/facemgr/CMakeLists.txt
@@ -41,6 +41,11 @@ if (NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release")
endif()
+if(CMAKE_BUILD_TYPE MATCHES Debug)
+message("IN DEBUG MODE")
+set(CMAKE_C_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -ggdb3")
+endif()
+
set(CMAKE_MODULE_PATH
${CMAKE_MODULE_PATH}
"${CMAKE_CURRENT_SOURCE_DIR}/../../cmake/Modules"