aboutsummaryrefslogtreecommitdiffstats
path: root/ctrl/libhicnctrl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ctrl/libhicnctrl/CMakeLists.txt')
-rw-r--r--ctrl/libhicnctrl/CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/ctrl/libhicnctrl/CMakeLists.txt b/ctrl/libhicnctrl/CMakeLists.txt
index 960eb6743..43d120473 100644
--- a/ctrl/libhicnctrl/CMakeLists.txt
+++ b/ctrl/libhicnctrl/CMakeLists.txt
@@ -35,7 +35,11 @@ set(CMAKE_MACOSX_RPATH ON)
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
- find_package_wrapper(Libhicn REQUIRED)
+ if (BUILD_CTRL_HICNPLUGIN AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
+ find_package_wrapper(HicnPlugin REQUIRED)
+ else ()
+ find_package_wrapper(Libhicn REQUIRED)
+ endif()
set(HICNCTRL hicnctrl)
set(LIBHICNCTRL hicnctrl)
@@ -48,6 +52,16 @@ else()
list(APPEND DEPENDENCIES
${LIBHICN_STATIC}
)
+ elseif (BUILD_CTRL_HICNPLUGIN AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
+ set(HICN_INCLUDE_DIRS
+ ${HICN_INCLUDE_DIRS}
+ ${HICNPLUGIN_INCLUDE_DIRS})
+
+ set(HICN_LIBRARIES ${HICNPLUGIN_LIBRARIES})
+
+ list(APPEND DEPENDENCIES
+ hicn_plugin
+ )
else ()
set(HICN_LIBRARIES ${LIBHICN_SHARED})
list(APPEND DEPENDENCIES