aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-light/src/hicn/command_line/controller/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hicn-light/src/hicn/command_line/controller/CMakeLists.txt')
-rw-r--r--hicn-light/src/hicn/command_line/controller/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/hicn-light/src/hicn/command_line/controller/CMakeLists.txt b/hicn-light/src/hicn/command_line/controller/CMakeLists.txt
index 68caa7dc8..4cbd49220 100644
--- a/hicn-light/src/hicn/command_line/controller/CMakeLists.txt
+++ b/hicn-light/src/hicn/command_line/controller/CMakeLists.txt
@@ -20,11 +20,16 @@ if (WIN32)
endif()
if (NOT DISABLE_EXECUTABLES)
+ if (${CMAKE_SYSTEM_NAME} MATCHES Android)
+ set(LINK_FLAGS "-Wl,--unresolved-symbols=ignore-in-object-files")
+ endif()
+
build_executable(${HICN_LIGHT_CONTROL}
SOURCES ${CONTROLLER_SRC}
- LINK_LIBRARIES ${HICN_LIGHT_LINK_LIBRARIES}
+ LINK_LIBRARIES ${LIBHICN_LIGHT_STATIC}
DEPENDS ${LIBHICN_LIGHT_STATIC}
COMPONENT ${HICN_LIGHT}
DEFINITIONS ${COMPILER_DEFINITIONS}
+ LINK_FLAGS ${LINK_FLAGS}
)
endif ()