aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-light/src/hicn/command_line/daemon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hicn-light/src/hicn/command_line/daemon/CMakeLists.txt')
-rw-r--r--hicn-light/src/hicn/command_line/daemon/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/hicn-light/src/hicn/command_line/daemon/CMakeLists.txt b/hicn-light/src/hicn/command_line/daemon/CMakeLists.txt
index ce62b51e2..a86826f09 100644
--- a/hicn-light/src/hicn/command_line/daemon/CMakeLists.txt
+++ b/hicn-light/src/hicn/command_line/daemon/CMakeLists.txt
@@ -14,14 +14,15 @@
list(APPEND DAEMON_SRC
hicnLightDaemon_main.c
)
+
if (WIN32)
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /NODEFAULTLIB:\"LIBCMT\"" )
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /NODEFAULTLIB:\"LIBCMT\"")
endif()
-if (NOT DISABLE_EXECUTABLES)
+if(NOT ${CMAKE_SYSTEM_NAME} STREQUAL "Android")
build_executable(${HICN_LIGHT_DAEMON}
SOURCES ${DAEMON_SRC}
- LINK_LIBRARIES ${HICN_LIGHT_LINK_LIBRARIES}
+ LINK_LIBRARIES ${LIBHICN_LIGHT_STATIC}
DEPENDS ${LIBHICN_LIGHT_STATIC}
COMPONENT ${HICN_LIGHT}
DEFINITIONS ${COMPILER_DEFINITIONS}