aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-light/src/platforms/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hicn-light/src/platforms/CMakeLists.txt')
-rw-r--r--hicn-light/src/platforms/CMakeLists.txt40
1 files changed, 0 insertions, 40 deletions
diff --git a/hicn-light/src/platforms/CMakeLists.txt b/hicn-light/src/platforms/CMakeLists.txt
deleted file mode 100644
index 191a72213..000000000
--- a/hicn-light/src/platforms/CMakeLists.txt
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright (c) 2017-2019 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
-
-if(${CMAKE_SYSTEM_NAME} STREQUAL "Android")
- list(APPEND SOURCE_FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/android/system.c
- )
-elseif(APPLE)
- list(APPEND SOURCE_FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/darwin/system.c
- )
-elseif( ${CMAKE_SYSTEM_NAME} STREQUAL "Linux" )
- list(APPEND SOURCE_FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/linux/system.c
- )
-elseif( ${CMAKE_SYSTEM_NAME} STREQUAL "Windows" )
- list(APPEND SOURCE_FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/windows/system.c
- ${CMAKE_CURRENT_SOURCE_DIR}/windows/win_portability.c
- )
- list(APPEND HEADER_FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/windows/win_portability.h
- )
-
-endif()
-
-set(SOURCE_FILES ${SOURCE_FILES} PARENT_SCOPE)
-set(HEADER_FILES ${HEADER_FILES} PARENT_SCOPE) \ No newline at end of file