aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hicn-plugin/CMakeLists.txt')
-rw-r--r--hicn-plugin/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/hicn-plugin/CMakeLists.txt b/hicn-plugin/CMakeLists.txt
index 1cd6f0411..be71b36a3 100644
--- a/hicn-plugin/CMakeLists.txt
+++ b/hicn-plugin/CMakeLists.txt
@@ -113,6 +113,8 @@ set(HICN_PLUGIN_SOURCE_FILES
src/strategies/dpo_mw.c
src/strategies/strategy_mw.c
src/strategies/strategy_mw_cli.c
+ src/strategies/dpo_rr.c
+ src/strategies/strategy_rr.c
src/cache_policies/cs_lru.c
src/mapme_ack_node.c
src/mapme_ctrl_node.c
@@ -158,6 +160,8 @@ set(HICN_PLUGIN_HEADER_FILES
src/pg.h
src/strategies/dpo_mw.h
src/strategies/strategy_mw.h
+ src/strategies/dpo_rr.h
+ src/strategies/strategy_rr.h
src/cache_policies/cs_policy.h
src/cache_policies/cs_lru.h
src/mapme.h
@@ -275,4 +279,4 @@ install(FILES ${HICN_API_TEST_HEADER_FILES} ${HICN_API_GENERATED_FILES}
install(FILES ${HICN_VAPI_GENERATED_FILES}
DESTINATION ${CMAKE_INSTALL_PREFIX}/include/vapi
- COMPONENT ${HICN_PLUGIN}) \ No newline at end of file
+ COMPONENT ${HICN_PLUGIN})