aboutsummaryrefslogtreecommitdiffstats
path: root/libtransport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libtransport/CMakeLists.txt')
-rw-r--r--libtransport/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/libtransport/CMakeLists.txt b/libtransport/CMakeLists.txt
index c5cb95260..4df87b056 100644
--- a/libtransport/CMakeLists.txt
+++ b/libtransport/CMakeLists.txt
@@ -44,7 +44,7 @@ set(raaqm_config_path ${CMAKE_INSTALL_PREFIX}/etc/hicn-consumer.conf)
# Install includes
set(INSTALL_INCLUDE_DIR include/hicn/transport)
-if ((BUILD_MEMIF_CONNECTOR OR BUILD_VPP_PLUGIN) AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
+if (BUILD_VPP_PLUGIN AND BUILD_MEMIF_CONNECTOR AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
set(__vpp__ 1)
find_package(Vpp REQUIRED)
find_package(Libmemif REQUIRED)
@@ -116,4 +116,4 @@ list(APPEND LIBTRANSPORT_INCLUDE_DIRS
${WINDOWS_INCLUDE_DIRS}
)
-add_subdirectory(${TRANSPORT_ROOT_PATH}) \ No newline at end of file
+add_subdirectory(${TRANSPORT_ROOT_PATH})