aboutsummaryrefslogtreecommitdiffstats
path: root/libtransport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libtransport/CMakeLists.txt')
-rwxr-xr-xlibtransport/CMakeLists.txt14
1 files changed, 4 insertions, 10 deletions
diff --git a/libtransport/CMakeLists.txt b/libtransport/CMakeLists.txt
index f2ade4520..097ab03ab 100755
--- a/libtransport/CMakeLists.txt
+++ b/libtransport/CMakeLists.txt
@@ -22,7 +22,6 @@ set(CMAKE_MODULE_PATH
)
include(DefaultConfiguration)
-include(Packager)
include(BuildMacros)
if (NOT CMAKE_BUILD_TYPE)
@@ -69,7 +68,7 @@ if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
if (__vpp__)
find_package_wrapper(HicnBinaryApi REQUIRED)
endif()
- set(LIBTRANSPORT transport)
+ set(LIBTRANSPORT hicntransport)
else()
set(HICN_LIBRARIES ${LIBHICN_SHARED})
list(APPEND DEPENDENCIES
@@ -84,6 +83,8 @@ else()
endif()
endif()
+include(Packaging)
+
find_package(Threads REQUIRED)
if (${COMPILE_TESTS})
@@ -112,11 +113,4 @@ list(APPEND LIBTRANSPORT_INCLUDE_DIRS
${ASIO_INCLUDE_DIRS}
)
-add_subdirectory(${TRANSPORT_ROOT_PATH})
-
-# Packaging
-add_package(libtransport
- NAME "libtransport"
- # DEPENDENCIES "fd.io" FIXME
- DESCRIPTION "Shared Memory Interface"
-)
+add_subdirectory(${TRANSPORT_ROOT_PATH}) \ No newline at end of file