aboutsummaryrefslogtreecommitdiffstats
path: root/libtransport/src/hicn/transport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libtransport/src/hicn/transport/CMakeLists.txt')
-rw-r--r--libtransport/src/hicn/transport/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/libtransport/src/hicn/transport/CMakeLists.txt b/libtransport/src/hicn/transport/CMakeLists.txt
index 82d478b65..4314ef908 100644
--- a/libtransport/src/hicn/transport/CMakeLists.txt
+++ b/libtransport/src/hicn/transport/CMakeLists.txt
@@ -15,13 +15,6 @@ cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
set(ASIO_STANDALONE 1)
-configure_file("config.h.in" "config.h" @ONLY)
-install(
- FILES ${CMAKE_CURRENT_BINARY_DIR}/config.h
- DESTINATION include/hicn/transport
- COMPONENT lib${LIBTRANSPORT}-dev
-)
-
add_subdirectory(core)
add_subdirectory(errors)
add_subdirectory(http)
@@ -30,6 +23,13 @@ add_subdirectory(portability)
add_subdirectory(protocols)
add_subdirectory(utils)
+configure_file("config.h.in" "config.h" @ONLY)
+install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/config.h
+ DESTINATION include/hicn/transport
+ COMPONENT lib${LIBTRANSPORT}-dev
+)
+
set (COMPILER_DEFINITIONS "")
list(INSERT LIBTRANSPORT_INCLUDE_DIRS 0