aboutsummaryrefslogtreecommitdiffstats
path: root/telemetry/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'telemetry/CMakeLists.txt')
-rw-r--r--telemetry/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/telemetry/CMakeLists.txt b/telemetry/CMakeLists.txt
new file mode 100644
index 000000000..53fd04f01
--- /dev/null
+++ b/telemetry/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright (c) 2020 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+
+cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
+
+if ((CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR) OR
+ (BUILD_HICNPLUGIN AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux"))
+ add_subdirectory(vpp-collectd)
+endif ()
+