aboutsummaryrefslogtreecommitdiffstats
path: root/telemetry/vpp-collectd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'telemetry/vpp-collectd/CMakeLists.txt')
-rw-r--r--telemetry/vpp-collectd/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/telemetry/vpp-collectd/CMakeLists.txt b/telemetry/vpp-collectd/CMakeLists.txt
new file mode 100644
index 000000000..18926b1c5
--- /dev/null
+++ b/telemetry/vpp-collectd/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Copyright (c) 2020 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
+
+set (COLLECTD_PLUGINS hicn-collectd-plugins)
+project(hicn-collectd-plugins)
+
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_CURRENT_SOURCE_DIR}/cmake/Modules/" "${CMAKE_CURRENT_SOURCE_DIR}/../../../cmake/Modules/")
+
+include(BuildMacros)
+
+
+add_subdirectory(vpp)
+add_subdirectory(vpp-hicn)
+
+include(Packaging)
+if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
+ include(Packager)
+ make_packages()
+endif()