aboutsummaryrefslogtreecommitdiffstats
path: root/telemetry/vpp-collectd/vpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'telemetry/vpp-collectd/vpp/CMakeLists.txt')
-rw-r--r--telemetry/vpp-collectd/vpp/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/telemetry/vpp-collectd/vpp/CMakeLists.txt b/telemetry/vpp-collectd/vpp/CMakeLists.txt
new file mode 100644
index 000000000..71fb7fc3d
--- /dev/null
+++ b/telemetry/vpp-collectd/vpp/CMakeLists.txt
@@ -0,0 +1,42 @@
+# Copyright (c) 2020 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
+
+# Dependencies
+
+list(APPEND SOURCE_FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/vpp.c
+)
+
+find_package(Vpp REQUIRED)
+find_package(Collectd REQUIRED)
+
+list (APPEND INCLUDE_DIRS
+ ${COLLECTD_INCLUDE_DIRS}
+ ${VPP_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_SOURCE_DIR})
+
+list (APPEND LIBRARIES
+ ${VPP_LIBRARY_VPPAPICLIENT}
+ ${VPP_LIBRARY_INFRA})
+
+build_library(vpp
+ SHARED
+ SOURCES ${SOURCE_FILES}
+ LINK_LIBRARIES ${LIBRARIES}
+ INCLUDE_DIRS ${INCLUDE_DIRS}
+ INSTALL_FULL_PATH_DIR ${CMAKE_INSTALL_PREFIX}/collectd
+ COMPONENT ${COLLECTD_PLUGINS}
+ EMPTY_PREFIX true
+ )