aboutsummaryrefslogtreecommitdiffstats
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utils/CMakeLists.txt')
-rw-r--r--utils/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index a377132e1..077789f57 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -29,7 +29,7 @@ if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
find_package(Libtransport REQUIRED)
set(HICN_UTILS hicn-utils)
else()
- set(LIBTRANSPORT_LIBRARIES ${LIBTRANSPORT})
+ set(LIBTRANSPORT_LIBRARIES ${LIBTRANSPORT_SHARED})
endif()
include(Packaging)
@@ -48,10 +48,9 @@ foreach(util ${UTILS_SRC})
build_executable(${util_name}
SOURCES ${util}
- LINK_LIBRARIES ${LIBTRANSPORT_LIBRARIES}
+ LINK_LIBRARIES ${LIBTRANSPORT_LIBRARIES} ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
DEPENDS ${LIBTRANSPORT}
- COMPONENT hicn-utils
+ COMPONENT ${HICN_UTILS}
DEFINITIONS ${COMPILER_DEFINITIONS}
- LINK_LIBRARIES ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
)
endforeach() \ No newline at end of file