aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/g2/Makefile.am
diff options
context:
space:
mode:
authorsreejith <sreejith.surendrannair@linaro.org>2017-03-29 01:15:02 -0400
committersreejith <sreejith.surendrannair@linaro.org>2017-03-29 02:23:59 -0400
commita23197980e40d4d9414bcfaf59005a1dc2a89251 (patch)
treeda3fc5410a9cda99e05d2e0f6dae06072a0c50b8 /vpp/g2/Makefile.am
parent746b57564deede624261ab8a96c94f562f24d22c (diff)
Added vpp intial source code from master branch 17.01.1
Change-Id: I81bdace6f330825a1746a853766779dfb24765fd Signed-off-by: sreejith <sreejith.surendrannair@linaro.org>
Diffstat (limited to 'vpp/g2/Makefile.am')
-rw-r--r--vpp/g2/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/vpp/g2/Makefile.am b/vpp/g2/Makefile.am
new file mode 100644
index 00000000..8457c272
--- /dev/null
+++ b/vpp/g2/Makefile.am
@@ -0,0 +1,34 @@
+# Copyright (c) 2016 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign
+
+bin_PROGRAMS = g2
+
+AM_CFLAGS = -Wall
+
+g2_SOURCES = \
+ clib.c \
+ cpel.c \
+ cpel.h \
+ events.c \
+ g2.h \
+ main.c \
+ menu1.c \
+ pointsel.c \
+ props.c \
+ props.h \
+ g2version.c \
+ view1.c
+
+g2_LDADD = $(g2_LIBS) -lvppinfra -lpthread -lm