aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/svm/Makefile.am
diff options
context:
space:
mode:
authorsreejith <sreejith.surendrannair@linaro.org>2017-03-29 01:15:02 -0400
committersreejith <sreejith.surendrannair@linaro.org>2017-03-29 02:23:59 -0400
commita23197980e40d4d9414bcfaf59005a1dc2a89251 (patch)
treeda3fc5410a9cda99e05d2e0f6dae06072a0c50b8 /vpp/svm/Makefile.am
parent746b57564deede624261ab8a96c94f562f24d22c (diff)
Added vpp intial source code from master branch 17.01.1
Change-Id: I81bdace6f330825a1746a853766779dfb24765fd Signed-off-by: sreejith <sreejith.surendrannair@linaro.org>
Diffstat (limited to 'vpp/svm/Makefile.am')
-rw-r--r--vpp/svm/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/vpp/svm/Makefile.am b/vpp/svm/Makefile.am
new file mode 100644
index 00000000..490e27b3
--- /dev/null
+++ b/vpp/svm/Makefile.am
@@ -0,0 +1,30 @@
+# Copyright (c) 2015 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign
+
+bin_PROGRAMS = svmtool svmdbtool
+
+AM_CFLAGS = -Wall
+
+nobase_include_HEADERS = svm.h ssvm.h svmdb.h
+
+lib_LTLIBRARIES = libsvm.la libsvmdb.la
+
+libsvm_la_SOURCES = svm.c ssvm.c
+
+svmtool_LDADD = libsvm.la -lvppinfra -lpthread -lrt
+
+libsvmdb_la_SOURCES = svmdb.c
+
+svmdbtool_LDADD = libsvmdb.la libsvm.la -lvppinfra -lpthread -lrt