aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/svm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vpp/svm/Makefile.am')
-rw-r--r--vpp/svm/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/vpp/svm/Makefile.am b/vpp/svm/Makefile.am
new file mode 100644
index 00000000..490e27b3
--- /dev/null
+++ b/vpp/svm/Makefile.am
@@ -0,0 +1,30 @@
+# Copyright (c) 2015 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign
+
+bin_PROGRAMS = svmtool svmdbtool
+
+AM_CFLAGS = -Wall
+
+nobase_include_HEADERS = svm.h ssvm.h svmdb.h
+
+lib_LTLIBRARIES = libsvm.la libsvmdb.la
+
+libsvm_la_SOURCES = svm.c ssvm.c
+
+svmtool_LDADD = libsvm.la -lvppinfra -lpthread -lrt
+
+libsvmdb_la_SOURCES = svmdb.c
+
+svmdbtool_LDADD = libsvmdb.la libsvm.la -lvppinfra -lpthread -lrt