aboutsummaryrefslogtreecommitdiffstats
path: root/build-data/packages/vnet.mk
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-04-01 12:35:17 +0200
committerGerrit Code Review <gerrit@fd.io>2016-04-01 15:22:15 +0000
commit28e3db9dd617324a3196f369788d62cc72b5903b (patch)
tree269e5356bf01e5565d7ac2006778dbad1be5edad /build-data/packages/vnet.mk
parentaa04a0ff8ee9aa7779b30e936f7fe1304c613d57 (diff)
Add options to link with external DPDK tree
By uncommenting following lines in the build-data/platforms/vpp.mk VPP links nicely with packaged DPDK 2.2 distributed with Ubuntu 16.04 LTS. vpp_uses_external_dpdk = yes vpp_dpdk_inc_dir = /usr/include/dpdk vpp_dpdk_lib_dir = /usr/lib vpp_dpdk_shared_lib = yes Change-Id: Id5b7d95bac6aa60341933b92e86d949a9abf1a5d Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'build-data/packages/vnet.mk')
-rw-r--r--build-data/packages/vnet.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/build-data/packages/vnet.mk b/build-data/packages/vnet.mk
index 0486b4e8e8d..2ff9034a045 100644
--- a/build-data/packages/vnet.mk
+++ b/build-data/packages/vnet.mk
@@ -22,7 +22,12 @@ vnet_LDFLAGS = $(call installed_libs_fn, \
vnet_configure_args += $(vnet_configure_args_$(PLATFORM))
ifneq ($($(PLATFORM)_uses_dpdk),no)
+ifeq ($($(PLATFORM)_uses_external_dpdk),yes)
+vnet_CPPFLAGS += -I$($(PLATFORM)_dpdk_inc_dir)
+vnet_LDFLAGS += -L$($(PLATFORM)_dpdk_lib_dir)
+else
vnet_configure_depend += dpdk-install
vnet_CPPFLAGS += $(call installed_includes_fn, dpdk)
vnet_LDFLAGS += $(call installed_libs_fn, dpdk)
endif
+endif