aboutsummaryrefslogtreecommitdiffstats
path: root/build-data/packages/vpp.mk
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-12-23 22:42:41 +0100
committerDamjan Marion <dmarion.lists@gmail.com>2016-12-26 14:53:35 +0000
commit696f1adec0df3b8f161862566dd9c86174302658 (patch)
tree0b7d382a829d573174838feb6e78a3fcba920627 /build-data/packages/vpp.mk
parent7d221611e19679fc4673f2a1d4f24d6002c2f105 (diff)
dpdk: Add support for Mellanox ConnectX-4 devices
Due to external library dependency support for Mellanox devices is disabled. To enable it uncoment following line: vpp_uses_dpdk_mlx5_pmd = yes in build-data/platforms/vpp.mk and install OFED libraries. Change-Id: I131d52b5d449a958349f31f9cc04311948f78b71 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'build-data/packages/vpp.mk')
-rw-r--r--build-data/packages/vpp.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/build-data/packages/vpp.mk b/build-data/packages/vpp.mk
index 6831c6b8644..a3d60528a01 100644
--- a/build-data/packages/vpp.mk
+++ b/build-data/packages/vpp.mk
@@ -48,4 +48,7 @@ endif
ifeq ($($(PLATFORM)_uses_dpdk_cryptodev),yes)
vpp_configure_args += --with-dpdk-crypto
endif
+ifeq ($($(PLATFORM)_uses_dpdk_mlx5_pmd),yes)
+vpp_configure_args += --with-dpdk-mlx5-pmd
+endif
endif