aboutsummaryrefslogtreecommitdiffstats
path: root/build/external/deb/debian
diff options
context:
space:
mode:
authorDave Wallace <dwallacelf@gmail.com>2024-05-15 18:16:40 -0400
committerFlorin Coras <florin.coras@gmail.com>2024-11-20 16:36:54 +0000
commit79c8f99ac928ab6108b3dd854b2ad389c4809ebb (patch)
tree2d998195b5b970285eefd1958db2da799d475757 /build/external/deb/debian
parent258b82975b120b3deb34483254f1d40dca5bb79d (diff)
build: add vpp-opt-deps package
- Build an optional vpp package for optional dynamically linked dependencies for vpp plugins. Initial package contents include openssl 3.3.2. - Refactor $WS_ROOT/build makefile structure - Remove vpp-ext-deps debian control replacement of vpp-dpdk-dev package Type: make Change-Id: I1af0eff4a0c009c9d9061362f79e2013d8bf1a93 Signed-off-by: Dave Wallace <dwallacelf@gmail.com>
Diffstat (limited to 'build/external/deb/debian')
-rw-r--r--build/external/deb/debian/control2
-rwxr-xr-xbuild/external/deb/debian/rules2
2 files changed, 1 insertions, 3 deletions
diff --git a/build/external/deb/debian/control b/build/external/deb/debian/control
index 80b81b8b375..a4e59f4c577 100644
--- a/build/external/deb/debian/control
+++ b/build/external/deb/debian/control
@@ -9,5 +9,3 @@ Package: vpp-ext-deps
Architecture: any
Depends: ${shlibs:Depends}
Description: VPP developer package containing dependencies
-Replaces: vpp-dpdk-dev
-Conflicts: vpp-dpdk-dev
diff --git a/build/external/deb/debian/rules b/build/external/deb/debian/rules
index 901d4689766..6682952fa0e 100755
--- a/build/external/deb/debian/rules
+++ b/build/external/deb/debian/rules
@@ -30,4 +30,4 @@ override_dh_install:
dh_install -p$(PKG) --autodest /opt
override_dh_shlibdeps:
- dh_shlibdeps -l$(INSTALL_DIR)lib/
+ dh_shlibdeps -l$(INSTALL_DIR)lib/:$(INSTALL_DIR)lib64