aboutsummaryrefslogtreecommitdiffstats
path: root/build/external/packages/quicly.mk
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2019-03-29 21:22:09 +0100
committerDamjan Marion <damarion@cisco.com>2019-03-29 21:23:30 +0100
commitd93638e128e7eb042a53440a3e762cf04e6c5190 (patch)
tree93dc3261106c6c3df624db8959d42d1a98afd957 /build/external/packages/quicly.mk
parente524d45eff40c773049e03ea5063216b469bbfcc (diff)
revert quicly related build/external changes
We dont't want git pull there, there is simple way to grab tarball from github for every single commit Change-Id: I7a98cab7660750e48084279d8b9892cdf229bceb Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'build/external/packages/quicly.mk')
-rw-r--r--build/external/packages/quicly.mk42
1 files changed, 0 insertions, 42 deletions
diff --git a/build/external/packages/quicly.mk b/build/external/packages/quicly.mk
deleted file mode 100644
index 246c73fb02d..00000000000
--- a/build/external/packages/quicly.mk
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright (c) 2019 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-quicly_repository := https://github.com/h2o/quicly.git
-quicly_version := f25b70d37f8974af9cc48a4a565d13a9cdc5fd75
-quicly_patch_dir := $(CURDIR)/patches/quicly
-
-picotls_build_dir := $(B)/build-picotls
-
-define quicly_build_cmds
- @cd $(quicly_build_dir) && \
- cmake -DCMAKE_INSTALL_PREFIX:PATH=$(quicly_install_dir) \
- $(quicly_src_dir) > $(quicly_build_log)
- @$(MAKE) $(MAKE_ARGS) -C $(quicly_build_dir) > $(quicly_build_log)
-
- @mkdir -p $(picotls_build_dir)
- @cd $(picotls_build_dir) && \
- cmake -DCMAKE_INSTALL_PREFIX:PATH=$(quicly_install_dir) \
- $(quicly_src_dir)/deps/picotls > $(quicly_build_log)
-endef
-
-define quicly_config_cmds
- @true
-endef
-
-define quicly_install_cmds
- @$(MAKE) $(MAKE_ARGS) -C $(quicly_build_dir) install > $(quicly_install_log)
- @$(MAKE) $(MAKE_ARGS) -C $(picotls_build_dir) install > $(quicly_install_log)
-endef
-
-
-$(eval $(call package,quicly))