aboutsummaryrefslogtreecommitdiffstats
path: root/build/external/packages/rdma-core.mk
diff options
context:
space:
mode:
authorBenoît Ganne <bganne@cisco.com>2019-04-08 13:45:33 +0200
committerDave Wallace <dwallacelf@gmail.com>2019-04-08 14:33:51 +0000
commitf3262a2dd0fd788b5ef3fc9592de17ef8bcbd897 (patch)
treed3df45a5a05a6b9ec374de177215fe97ff3e50c6 /build/external/packages/rdma-core.mk
parent7f6bd24f7217026131f6b8e1e55f92d2955c883b (diff)
rdma: fix DPDK MLX driver conflict
VPP rdma driver relies on an internal rdma-core not compatible with DPDK MLX driver. Force the use of external rdma-core through RTE_IBVERBS_LINK_DLOPEN DPDK build option and make sure internal rdma-core symbols are not leaked outside of the rdma plugin. Change-Id: I5b2281259f517c4e109d388d172b72eadd69986f Signed-off-by: Benoît Ganne <bganne@cisco.com>
Diffstat (limited to 'build/external/packages/rdma-core.mk')
-rw-r--r--build/external/packages/rdma-core.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/build/external/packages/rdma-core.mk b/build/external/packages/rdma-core.mk
index 82a5f0fbdb0..9961c80364f 100644
--- a/build/external/packages/rdma-core.mk
+++ b/build/external/packages/rdma-core.mk
@@ -31,7 +31,7 @@ define rdma-core_config_cmds
$(CMAKE) -G Ninja $(rdma-core_src_dir) \
-DENABLE_STATIC=1 -DENABLE_RESOLVE_NEIGH=0 -DNO_PYVERBS=1 -DENABLE_VALGRIND=0 \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_C_FLAGS=-fPIC > $(rdma-core_config_log)
+ -DCMAKE_C_FLAGS='-fPIC -fvisibility=hidden' > $(rdma-core_config_log)
endef
define rdma-core_build_cmds