aboutsummaryrefslogtreecommitdiffstats
path: root/build/optional/deb/debian/rules
diff options
context:
space:
mode:
authorDave Wallace <dwallacelf@gmail.com>2024-05-15 18:16:40 -0400
committerFlorin Coras <florin.coras@gmail.com>2024-11-20 16:36:54 +0000
commit79c8f99ac928ab6108b3dd854b2ad389c4809ebb (patch)
tree2d998195b5b970285eefd1958db2da799d475757 /build/optional/deb/debian/rules
parent258b82975b120b3deb34483254f1d40dca5bb79d (diff)
build: add vpp-opt-deps package
- Build an optional vpp package for optional dynamically linked dependencies for vpp plugins. Initial package contents include openssl 3.3.2. - Refactor $WS_ROOT/build makefile structure - Remove vpp-ext-deps debian control replacement of vpp-dpdk-dev package Type: make Change-Id: I1af0eff4a0c009c9d9061362f79e2013d8bf1a93 Signed-off-by: Dave Wallace <dwallacelf@gmail.com>
Diffstat (limited to 'build/optional/deb/debian/rules')
-rwxr-xr-xbuild/optional/deb/debian/rules33
1 files changed, 33 insertions, 0 deletions
diff --git a/build/optional/deb/debian/rules b/build/optional/deb/debian/rules
new file mode 100755
index 00000000000..2fd8b3d110d
--- /dev/null
+++ b/build/optional/deb/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+DH_VERBOSE = 1
+DEB_BUILD_OPTIONS = noddebs
+DEB_CFLAGS_MAINT_STRIP = -flto=auto -ffat-lto-objects -flto=auto -ffat-lto-objects -O2
+DEB_LDFLAGS_MAINT_STRIP = -flto=auto -ffat-lto-objects -flto=auto -ffat-lto-objects
+DEB_CFLAGS_MAINT_APPEND = -O3
+PKG=vpp-opt-deps
+
+VERSION = $(shell dpkg-parsechangelog | sed -nr '/^Version:/s/Version: //p')
+BASE_VER = $(word 1, $(subst -, ,$(VERSION)))
+
+export BUILD_DIR=$(CURDIR)/_build
+export INSTALL_DIR=$(CURDIR)/debian/tmp/opt/vpp/optional/$(shell uname -m)/
+
+MAKE_ARGS=-C ..
+
+include /usr/share/dpkg/default.mk
+
+%:
+ dh $@
+
+override_dh_clean:
+ make $(MAKE_ARGS) clean
+
+override_dh_auto_configure:
+
+override_dh_install:
+ make $(MAKE_ARGS) install
+ @mkdir -p $(INSTALL_DIR)
+ dh_install -p$(PKG) --autodest /opt
+
+override_dh_shlibdeps:
+ dh_shlibdeps -l$(INSTALL_DIR)lib/:$(INSTALL_DIR)lib64