aboutsummaryrefslogtreecommitdiffstats
path: root/build/optional/packages/openssl.mk
diff options
context:
space:
mode:
authorDave Wallace <dwallacelf@gmail.com>2024-05-15 18:16:40 -0400
committerFlorin Coras <florin.coras@gmail.com>2024-11-20 16:36:54 +0000
commit79c8f99ac928ab6108b3dd854b2ad389c4809ebb (patch)
tree2d998195b5b970285eefd1958db2da799d475757 /build/optional/packages/openssl.mk
parent258b82975b120b3deb34483254f1d40dca5bb79d (diff)
build: add vpp-opt-deps package
- Build an optional vpp package for optional dynamically linked dependencies for vpp plugins. Initial package contents include openssl 3.3.2. - Refactor $WS_ROOT/build makefile structure - Remove vpp-ext-deps debian control replacement of vpp-dpdk-dev package Type: make Change-Id: I1af0eff4a0c009c9d9061362f79e2013d8bf1a93 Signed-off-by: Dave Wallace <dwallacelf@gmail.com>
Diffstat (limited to 'build/optional/packages/openssl.mk')
-rw-r--r--build/optional/packages/openssl.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/build/optional/packages/openssl.mk b/build/optional/packages/openssl.mk
new file mode 100644
index 00000000000..1c9c45b8cd7
--- /dev/null
+++ b/build/optional/packages/openssl.mk
@@ -0,0 +1,44 @@
+# Copyright (c) 2024 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+openssl_version := 3.3.2
+openssl_tarball := openssl-$(openssl_version).tar.gz
+openssl_tarball_md5sum := 015fca2692596560b6fe8a2d8fecd84b
+
+openssl_tarball_strip_dirs := 1
+openssl_url := https://github.com/openssl/openssl/releases/download/openssl-$(openssl_version)/$(openssl_tarball)
+
+define openssl_config_args
+--prefix=$(openssl_install_dir) \
+--openssldir=$(openssl_build_dir) \
+no-dtls1
+endef
+
+define openssl_config_cmds
+ @cd $(openssl_src_dir) && \
+ $(openssl_src_dir)/config \
+ $(openssl_config_args) | tee -a $(openssl_config_log)
+endef
+
+define openssl_build_cmds
+ @cd $(openssl_src_dir) && \
+ $(MAKE) depend build_sw | tee $(openssl_build_log)
+endef
+
+define openssl_install_cmds
+ @cd $(openssl_src_dir) && \
+ $(MAKE) install_sw | tee $(openssl_install_log)
+endef
+
+$(eval $(call package,openssl))
+