aboutsummaryrefslogtreecommitdiffstats
path: root/extras/apps/Makefile.am
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2017-12-11 11:49:26 -0800
committerDave Barach <openvpp@barachs.net>2017-12-15 19:05:57 +0000
commit891f0a1caa795ed7799f0c6faa1cb91b4669d4da (patch)
tree01c5ad6620b0445a9cd19310cfb99affa3c277c8 /extras/apps/Makefile.am
parentce07412a54f06900b377a7f4966f6a26e19b8f2b (diff)
apps: refactor uri and update build infra
Change-Id: Ifa9966a27586a1a65038d069cf4a1e6e21a72d45 Signed-off-by: Florin Coras <fcoras@cisco.com>
Diffstat (limited to 'extras/apps/Makefile.am')
-rw-r--r--extras/apps/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/extras/apps/Makefile.am b/extras/apps/Makefile.am
new file mode 100644
index 00000000000..5bff2469647
--- /dev/null
+++ b/extras/apps/Makefile.am
@@ -0,0 +1,41 @@
+# Copyright (c) 2017 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign subdir-objects
+
+ACLOCAL_AMFLAGS = -I m4
+
+AM_CFLAGS = -Wall
+
+SRCS_C := $(shell find . -name "*.c" )
+SRCS_H := $(shell find . -name "*.h" )
+
+.PHONY: fixstyle
+fixstyle:
+ @echo Fixing code style...
+ indent $(SRCS_C) $(SRCS_H)
+ @echo Code style fixed!
+
+#
+# Socket client and server apps
+#
+socket_echo_client_SOURCES = src/socket_echo_client.c
+socket_echo_client_LDADD = -lvppinfra
+socket_echo_client_CFLAGS = $(AM_CPPFLAGS) -Isrc
+
+socket_echo_server_SOURCES = src/socket_echo_server.c
+socket_echo_server_LDADD = -lvppinfra
+socket_echo_server_CFLAGS = $(AM_CPPFLAGS) -Isrc
+
+noinst_PROGRAMS = socket_echo_client socket_echo_server
+