aboutsummaryrefslogtreecommitdiffstats
path: root/extras/deprecated/plugins/l2e/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2020-09-14 07:41:48 +0000
committerDamjan Marion <dmarion@me.com>2021-11-23 13:03:36 +0000
commit3be9164f80ebb1929488bbe2ee4da1d35f42c1a2 (patch)
tree3fdd1b7cefd596a9fb3d8cef171985b82405d6e4 /extras/deprecated/plugins/l2e/CMakeLists.txt
parent0a7551bef872363bd3a25129bdc91dbf2a3b1ee2 (diff)
misc: deprecate gbp and its dependents
Type: improvement Signed-off-by: Neale Ranns <nranns@cisco.com> Signed-off-by: BenoƮt Ganne <bganne@cisco.com> Change-Id: I2f30a4f04fd9a8635ce2d259b5fd5b0c85cee8c3
Diffstat (limited to 'extras/deprecated/plugins/l2e/CMakeLists.txt')
-rw-r--r--extras/deprecated/plugins/l2e/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/extras/deprecated/plugins/l2e/CMakeLists.txt b/extras/deprecated/plugins/l2e/CMakeLists.txt
new file mode 100644
index 00000000000..2bfb05a43e6
--- /dev/null
+++ b/extras/deprecated/plugins/l2e/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(l2e
+ SOURCES
+ l2e_node.c
+ l2e_api.c
+ l2e.c
+
+ MULTIARCH_SOURCES
+ l2e_node.c
+
+ API_FILES
+ l2e.api
+
+ INSTALL_HEADERS
+ l2e.h
+)