aboutsummaryrefslogtreecommitdiffstats
path: root/extras/libmemif/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJakub Grajciar <jgrajcia@cisco.com>2021-01-04 10:17:46 +0100
committerDamjan Marion <dmarion@me.com>2021-09-27 14:35:45 +0000
commit24681606b9e1f78436846ef3de936829c03b5ca9 (patch)
tree84489b3cb01475436728638d9e446ae77be9accb /extras/libmemif/test/CMakeLists.txt
parent0faf38876138555aefaa89609c2e1fd409acafa5 (diff)
libmemif: remove outdated unit tests
Type: refactor Signed-off-by: Jakub Grajciar <jgrajcia@cisco.com> Change-Id: Ie42c03980cf2cc0766308043d7d3ea5301a59b75
Diffstat (limited to 'extras/libmemif/test/CMakeLists.txt')
-rw-r--r--extras/libmemif/test/CMakeLists.txt35
1 files changed, 0 insertions, 35 deletions
diff --git a/extras/libmemif/test/CMakeLists.txt b/extras/libmemif/test/CMakeLists.txt
deleted file mode 100644
index 79754a2f8b7..00000000000
--- a/extras/libmemif/test/CMakeLists.txt
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright (c) 2017 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
-
-set(HEADERS_DIR ${CMAKE_CURRENT_SOURCE_DIR})
-set(TEST_NAME libmemif-test)
-set(TEST_LIBS m rt)
-
-find_package(Subunit QUIET)
-if (NOT SUBUNIT_LIBRARY)
- set(SUBUNIT_LIBRARY "")
-endif ()
-
-set(SOURCE_FILES
- main_test.c
- socket_test.c
- unit_test.c
-)
-
-add_executable(${TEST_NAME} ${SOURCE_FILES})
-target_include_directories(${TEST_NAME} PRIVATE $<BUILD_INTERFACE:${HEADERS_DIR}>)
-target_link_libraries(${TEST_NAME} memif ${CHECK_LIBRARY} ${SUBUNIT_LIBRARY} ${TEST_LIBS} ${CMAKE_THREAD_LIBS_INIT})
-
-add_test(unit_test unit-test)