aboutsummaryrefslogtreecommitdiffstats
path: root/extras/libmemif/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2020-05-07 16:49:45 +0200
committerFlorin Coras <florin.coras@gmail.com>2020-05-08 17:01:32 +0000
commit599efc67e87e89666d44efd34b5d3db7ccf1f4ca (patch)
tree5ced205cb5ff5247e8e9b596295d4ab4d60319c5 /extras/libmemif/test/CMakeLists.txt
parent13f64ce2272539d97b8c499e8e298a053fb3c9e2 (diff)
build: various improvements
- add option to install only host tools - add option to specify lib and runtime dir Type: improvement Change-Id: I6356b52df459120fc9b0127948bae7679fb10e52 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'extras/libmemif/test/CMakeLists.txt')
-rw-r--r--extras/libmemif/test/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/extras/libmemif/test/CMakeLists.txt b/extras/libmemif/test/CMakeLists.txt
index 3681fd3e64b..79754a2f8b7 100644
--- a/extras/libmemif/test/CMakeLists.txt
+++ b/extras/libmemif/test/CMakeLists.txt
@@ -30,6 +30,6 @@ set(SOURCE_FILES
add_executable(${TEST_NAME} ${SOURCE_FILES})
target_include_directories(${TEST_NAME} PRIVATE $<BUILD_INTERFACE:${HEADERS_DIR}>)
-target_link_libraries(${TEST_NAME} ${LIBMEMIF} ${CHECK_LIBRARY} ${SUBUNIT_LIBRARY} ${TEST_LIBS} ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries(${TEST_NAME} memif ${CHECK_LIBRARY} ${SUBUNIT_LIBRARY} ${TEST_LIBS} ${CMAKE_THREAD_LIBS_INIT})
-add_test(unit_test unit-test) \ No newline at end of file
+add_test(unit_test unit-test)