aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/ila-plugin/Makefile.am
diff options
context:
space:
mode:
authorPierre Pfister <ppfister@cisco.com>2016-07-16 08:51:16 +0100
committerDamjan Marion <damarion@cisco.com>2016-07-17 14:00:16 +0200
commitfd8181b694f97376c880e6b70ec63a8a678ef613 (patch)
treedfcaf81c478691e679c7eeed41be0fab44e7ccbf /plugins/ila-plugin/Makefile.am
parent7d6b81e3191fda5327e7ca54b305ea26357f4c7a (diff)
Add ILA plugin
This plugin is implementation of Identifier Locator Addressing (ILA) per IETF draft-herbert-nvo3-ila-2 Change-Id: I5d5f8fb55c490f358f628bceb5f57e7e7408e6ed Signed-off-by: Pierre Pfister <ppfister@cisco.com> Signed-off-by: Wolfgang <wolfgang.beck01@gmail.com> Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'plugins/ila-plugin/Makefile.am')
-rw-r--r--plugins/ila-plugin/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/plugins/ila-plugin/Makefile.am b/plugins/ila-plugin/Makefile.am
new file mode 100644
index 00000000000..fe785df9bc3
--- /dev/null
+++ b/plugins/ila-plugin/Makefile.am
@@ -0,0 +1,29 @@
+# Copyright (c) 2016 Cisco Systems, Inc.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign subdir-objects
+
+AM_CFLAGS = -Wall
+AM_LDFLAGS = -module -shared -avoid-version
+
+vpppluginsdir = ${libdir}/vpp_plugins
+
+vppplugins_LTLIBRARIES = ila_plugin.la
+
+ila_plugin_la_SOURCES = ila/ila.c
+
+noinst_HEADERS = ila/ila.h
+
+# Remove *.la files
+install-data-hook:
+ @(cd $(vpppluginsdir) && $(RM) $(vppplugins_LTLIBRARIES))