aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/ioam-plugin/Makefile.am
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-07-07 20:27:49 +0200
committerDave Barach <openvpp@barachs.net>2016-07-08 10:43:38 +0000
commit905a7f5520a64aad545c8dd02796b56f88ed2d38 (patch)
treefb2da8de6ac2bbf1a35bcf2b87251c9a94a23fc8 /plugins/ioam-plugin/Makefile.am
parent370e9e38e8e0b35810734125e2b6eeac65fefa5d (diff)
Multiple changes in the plugin build infra
- configure.ac - some plugins are enabled by default - Plugin .so files are placed into corresponding subdirs - WITH_PLUGIN_TOOLKIT macro is retired - not needed anymore - plugins/build-data is removed - plugin makefiles are not building static libs anymore - plugin makefiles are not installing header files to /usr/include anymore Change-Id: I55681bd9ce34811f7eb1b2b24d9f0ca42df1cf04 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'plugins/ioam-plugin/Makefile.am')
-rw-r--r--plugins/ioam-plugin/Makefile.am23
1 files changed, 11 insertions, 12 deletions
diff --git a/plugins/ioam-plugin/Makefile.am b/plugins/ioam-plugin/Makefile.am
index e62525f155a..47ff11671f9 100644
--- a/plugins/ioam-plugin/Makefile.am
+++ b/plugins/ioam-plugin/Makefile.am
@@ -13,7 +13,8 @@
AUTOMAKE_OPTIONS = foreign subdir-objects
-AM_CFLAGS = -Wall -I@TOOLKIT_INCLUDE@
+AM_CFLAGS = -Wall
+AM_LDFLAGS = -module -shared -avoid-version
########################################
# iOAM Proof of Transit
@@ -26,8 +27,6 @@ ioam_pot_plugin_la_SOURCES = \
ioam/lib-pot/math64.h \
ioam/lib-pot/pot_api.c
-ioam_pot_plugin_la_LDFLAGS = -module
-
BUILT_SOURCES = \
ioam/lib-pot/pot.api.h
@@ -38,7 +37,7 @@ SUFFIXES = .api.h .api
$(CC) $(CPPFLAGS) -E -P -C -x c $^ \
| vppapigen --input - --output $@ --show-name $@
-nobase_include_HEADERS = \
+noinst_HEADERS = \
ioam/lib-pot/pot_all_api_h.h \
ioam/lib-pot/pot_msg_enum.h \
ioam/lib-pot/pot.api.h \
@@ -49,14 +48,14 @@ ioam_pot_test_plugin_la_SOURCES = \
ioam/lib-pot/pot_test.c \
ioam/lib-pot/pot_plugin.api.h
-ioam_pot_test_plugin_la_LDFLAGS = -module
+vppapitestpluginsdir = ${libdir}/vpp_api_test_plugins
+vpppluginsdir = ${libdir}/vpp_plugins
+
+vppapitestplugins_LTLIBRARIES = ioam_pot_test_plugin.la
+vppplugins_LTLIBRARIES = ioam_pot_plugin.la
-lib_LTLIBRARIES = ioam_pot_plugin.la ioam_pot_test_plugin.la
-if WITH_PLUGIN_TOOLKIT
+# Remove *.la files
install-data-hook:
- mkdir /usr/lib/vpp_plugins || true
- mkdir /usr/lib/vpp_api_test_plugins || true
- cp -L $(prefix)/lib/ioam_pot_plugin.so /usr/lib/vpp_plugins
- cp -L $(prefix)/lib/ioam_pot_test_plugin.so /usr/lib/vpp_api_test_plugins
-endif
+ @(cd $(vpppluginsdir) && $(RM) $(vppplugins_LTLIBRARIES))
+ @(cd $(vppapitestpluginsdir) && $(RM) $(vppapitestplugins_LTLIBRARIES))