aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/snat-plugin/Makefile.am
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2016-06-26 10:42:08 -0400
committerKeith Burns <alagalah@gmail.com>2016-07-01 18:20:13 +0000
commit20c02cb133cf7b8a0570b83acf927d5a0d601a36 (patch)
treec5358223dab1b0be982fd0f29d8414868393247f /plugins/snat-plugin/Makefile.am
parentb8dca74c232d6f177479d644dc3359b82772ea9e (diff)
Simple ip4 NAT plugin
Change-Id: Iffe77bf2a05ced41474540ff54a842101aad7c41 Signed-off-by: Dave Barach <dave@barachs.net>
Diffstat (limited to 'plugins/snat-plugin/Makefile.am')
-rw-r--r--plugins/snat-plugin/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/plugins/snat-plugin/Makefile.am b/plugins/snat-plugin/Makefile.am
new file mode 100644
index 00000000000..11b0839a6c9
--- /dev/null
+++ b/plugins/snat-plugin/Makefile.am
@@ -0,0 +1,55 @@
+
+# Copyright (c) <current-year> <your-organization>
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign subdir-objects
+
+AM_CFLAGS = -Wall -I@TOOLKIT_INCLUDE@ @DPDK@
+
+lib_LTLIBRARIES = snat_plugin.la snat_test_plugin.la
+
+snat_plugin_la_SOURCES = snat/snat.c \
+ snat/in2out.c \
+ snat/out2in.c \
+ snat/snat_plugin.api.h
+
+snat_plugin_la_LDFLAGS = -module
+
+BUILT_SOURCES = snat/snat.api.h
+
+SUFFIXES = .api.h .api
+
+%.api.h: %.api
+ mkdir -p `dirname $@` ; \
+ $(CC) $(CPPFLAGS) -E -P -C -x c $^ \
+ | vppapigen --input - --output $@ --show-name $@
+
+nobase_include_HEADERS = \
+ snat/snat_all_api_h.h \
+ snat/snat_msg_enum.h \
+ snat/snat.api.h
+
+snat_test_plugin_la_SOURCES = \
+ snat/snat_test.c snat/snat_plugin.api.h
+snat_test_plugin_la_LDFLAGS = -module
+
+if WITH_PLUGIN_TOOLKIT
+install-data-hook:
+ mkdir /usr/lib/vpp_plugins || true
+ mkdir /usr/lib/vpp_api_test_plugins || true
+ cp -L $(prefix)/lib/snat_plugin.so /usr/lib/vpp_plugins
+ cp -L $(prefix)/lib/snat_test_plugin.so \
+ /usr/lib/vpp_api_test_plugins
+ rm -f $(prefix)/lib/snat_plugin.*
+ rm -f $(prefix)/lib/snat_test_plugin.*
+endif