aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2021-04-30 11:11:08 +0200
committerDamjan Marion <damarion@cisco.com>2021-04-30 11:15:47 +0200
commit1bb67abf3c6816b6f2c22eaeb1bdc355c4c95a46 (patch)
tree2d30392d619affa3073bfc9d15151f71c7a4fc37 /src/CMakeLists.txt
parent600d7a85fbdd9f3c7c6977faa07fee7e2e13ce21 (diff)
build: switch release build to -O3
Type: make Change-Id: Ia39c2f847e7b4907fdd3fcac75897b8b4c545a65 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index eb598784cb8..7dfd76a960d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -76,7 +76,7 @@ endif()
# release
list(APPEND BUILD_TYPES "release")
string(CONCAT CMAKE_C_FLAGS_RELEASE
- "-O2 "
+ "-O3 "
"-fstack-protector "
"-D_FORTIFY_SOURCE=2 "
"-fno-common "