aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2021-11-06 17:09:37 +0100
committerBeno�t Ganne <bganne@cisco.com>2021-11-08 16:39:06 +0000
commit1e26724dce437566fb645374d41f7b18a7199937 (patch)
tree0adaef9bf852cde1b0e8d15a389142cdf4b4caaa /src/CMakeLists.txt
parent81865bc0e3cfe2cf384640740ccbb18cc9a96163 (diff)
build: -Wno-stringop-overflow during LTO phase
Type: make Change-Id: I735fa411366c41981e255921eceb18ebbb4b5fe1 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 5327735b0ce..3966bc322ce 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -125,6 +125,10 @@ if (CMAKE_BUILD_TYPE_UC STREQUAL "RELEASE")
endif()
endif()
+if(VPP_USE_LTO)
+ check_c_compiler_flag("-Wno-stringop-overflow"
+ compiler_flag_no_stringop_overflow)
+endif()
##############################################################################
# sanitizers
##############################################################################