aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <neale@graphiant.com>2021-01-20 09:03:30 +0000
committerDamjan Marion <dmarion@me.com>2021-01-20 11:00:11 +0000
commit2a81d9a4cc3436d63dad618ec654572343e89257 (patch)
tree6f71de21fdb617c5bd9c697a0baef630fed5b962 /src/CMakeLists.txt
parentdf849f8ea8750e934a7a2c9ea2d5628b0c209056 (diff)
build: add the missing leading underscore to FORTIFY_SOURCE
Type: fix Signed-off-by: Neale Ranns <neale@graphiant.com> Change-Id: I36f2d08681f90a3f8ea7598952d1e14c53f0187b
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 15e06739685..0b06a4cf871 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -70,7 +70,7 @@ list(APPEND BUILD_TYPES "release")
string(CONCAT CMAKE_C_FLAGS_RELEASE
"-O2 "
"-fstack-protector "
- "-DFORTIFY_SOURCE=2 "
+ "-D_FORTIFY_SOURCE=2 "
"-fno-common "
)
@@ -82,7 +82,7 @@ string(CONCAT CMAKE_C_FLAGS_DEBUG
"-O0 "
"-DCLIB_DEBUG "
"-fstack-protector "
- "-DFORTIFY_SOURCE=2 "
+ "-D_FORTIFY_SOURCE=2 "
"-fno-common "
)