aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2021-05-03 12:40:27 +0200
committerDamjan Marion <dmarion@me.com>2021-05-04 07:18:17 +0000
commit3a533cd561eb75deab489d5ab39a7ec4e1bf7952 (patch)
treefa03c3a87b414b924bd20aae09932a2b77441c4b /src/CMakeLists.txt
parentba9cb1ba377b2ec7b2876822d73db848e7fa6754 (diff)
build: add set-build-type-* targets to CMake
Type: make Change-Id: Icf37873b461cd034567dc1b99e23d1bbb3f4b9f0 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a291c4d022d..cb05a087b6c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -110,9 +110,9 @@ string(CONCAT CMAKE_C_FLAGS_GCOV
string(TOUPPER "${CMAKE_BUILD_TYPE}" CMAKE_BUILD_TYPE_UC)
-string(REPLACE ";" " " BUILD_TYPES "${BUILD_TYPES}")
+string(REPLACE ";" " " BUILD_TYPES_STR "${BUILD_TYPES}")
set_property(CACHE CMAKE_BUILD_TYPE PROPERTY
- HELPSTRING "Build type - valid options are: ${BUILD_TYPES}")
+ HELPSTRING "Build type - valid options are: ${BUILD_TYPES_STR}")
##############################################################################
# link time optimizations
@@ -245,6 +245,14 @@ add_custom_target(compdb
USES_TERMINAL
)
+foreach(bt ${BUILD_TYPES})
+ add_custom_target(set-build-type-${bt}
+ COMMAND cmake -DCMAKE_BUILD_TYPE:STRING=${bt} .
+ COMMENT "Changing build type to ${bt}"
+ USES_TERMINAL
+ )
+endforeach()
+
##############################################################################
# print configuration
##############################################################################