aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2022-04-25 12:38:40 +0200
committerDamjan Marion <damarion@cisco.com>2022-04-25 13:49:37 +0200
commit45e05396399b7ead25d87e79a806f0c03b78965b (patch)
treebcd50ce7d197e2351d2f1d1816b9428111dd7825 /src/CMakeLists.txt
parent4e6222d598d5ec9db1b1e06bb3a45aca76a37daa (diff)
build: add option to build only for native CPU
Significantly reduces compilation time for uses who are interested to run binaries only on the build machine. Type: make Change-Id: I431f6f7374b6dfa8b3f7c72dc69f3d5cafd1f6bb Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index de0c24135d7..2fb0703e174 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -299,3 +299,4 @@ pr("Target processor" ${CMAKE_SYSTEM_PROCESSOR})
pr("Prefix path" ${CMAKE_PREFIX_PATH})
pr("Install prefix" ${CMAKE_INSTALL_PREFIX})
pr("Library dir" ${VPP_LIBRARY_DIR})
+pr("Multiarch variants" ${MARCH_VARIANTS_NAMES})