aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2019-01-28 17:55:59 +0100
committerMarco Varlese <marco.varlese@suse.de>2019-01-29 07:47:01 +0000
commit6077c97a60e06e17f8d33070ee3e4843c190f28d (patch)
tree215ae45cf2c4e6034cffbf28dcfff34c0a2830e9 /src/CMakeLists.txt
parent7da100bd0484c8e28fd25f8cc9f3dcdbf27ec489 (diff)
cmake: fix out-of-git-tree build
Change-Id: Ib94637ec09799c23f3179599b54a2be6e2768425 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b83d44e7567..161e3c57c44 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -110,16 +110,6 @@ foreach(DIR ${SUBDIRS})
endforeach()
##############################################################################
-# packaging
-##############################################################################
-include(cmake/pack.cmake)
-add_vpp_packaging(
- NAME "vpp"
- VENDOR "fd.io"
- DESCRIPTION "Vector Packet Processor"
-)
-
-##############################################################################
# detect if we are inside git repo and add configure dependency
##############################################################################
execute_process(
@@ -127,6 +117,7 @@ execute_process(
COMMAND git rev-parse --show-toplevel
OUTPUT_VARIABLE VPP_GIT_TOPLEVEL_DIR
OUTPUT_STRIP_TRAILING_WHITESPACE
+ ERROR_QUIET
)
if (VPP_GIT_TOPLEVEL_DIR)