aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2021-12-03 14:07:41 +0100
committerOle Tr�an <otroan@employees.org>2021-12-06 12:27:22 +0000
commit9c412e9ee58ae4a2671d63f70add6fd2c6c15a2b (patch)
tree3262ce0b11a1afbd6e66053f016a1db221a1df16 /src/CMakeLists.txt
parentc14b8cfe601b7b56e946e5f518e82a47e223c721 (diff)
build: leave to CMake to deal with -fPIE
Type: make Change-Id: Icced0e09b75b3114b1652d552e288091968ee7cc Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 46948a2aff3..32f0e7edcdc 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -74,7 +74,7 @@ set(VPP_BINARY_DIR ${CMAKE_BINARY_DIR}/CMakeFiles)
set(PYENV PYTHONPYCACHEPREFIX=${CMAKE_BINARY_DIR}/CMakeFile/__pycache__)
if (CMAKE_BUILD_TYPE)
- add_compile_options(-g -fPIC -Werror -Wall)
+ add_compile_options(-g -Werror -Wall)
endif()
if (compiler_flag_no_address_of_packed_member)
@@ -90,7 +90,6 @@ set(CMAKE_C_FLAGS_DEBUG "")
if (${CMAKE_BUILD_TYPE_LC} MATCHES "release")
add_compile_options(-O3 -fstack-protector -fno-common)
add_compile_definitions(_FORTIFY_SOURCE=2)
- add_link_options("-pie")
elseif (${CMAKE_BUILD_TYPE_LC} MATCHES "debug")
add_compile_options(-O0 -fstack-protector -fno-common)
add_compile_definitions(CLIB_DEBUG)