aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMohammed Hawari <mohammed@hawari.fr>2021-01-22 14:30:56 +0100
committerNeale Ranns <neale@graphiant.com>2021-01-28 08:38:21 +0000
commitb78607b1db72173bffabc950253a3894c032cb5c (patch)
tree39458f32b0fa2fceeb75fc7053733b4daf067503 /src/CMakeLists.txt
parent27df7979782aafca80ea4c7309284bd48fe021c0 (diff)
build: do not _FORTIFY_SOURCE in debug mode
When compiling in -O0, the glibc feature.h ignores _FORTIFY_SOURCE and, in some distributions, throws a #warning, which fails the build. This patch removes -D_FORTIFY_SOURCE in all debug configurations. Change-Id: Ic30229c038353e49ff9419779e082a7083c1ea5f Type: fix Signed-off-by: Mohammed Hawari <mohammed@hawari.fr>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0b06a4cf871..4d66671edc5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -82,7 +82,6 @@ string(CONCAT CMAKE_C_FLAGS_DEBUG
"-O0 "
"-DCLIB_DEBUG "
"-fstack-protector "
- "-D_FORTIFY_SOURCE=2 "
"-fno-common "
)