aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGuillaume Solignac <gsoligna@cisco.com>2024-01-11 13:39:11 +0100
committerDamjan Marion <dmarion@0xa5.net>2024-01-16 22:34:43 +0000
commitde04e023cbd469b26e80602f8f91934b7e984fb9 (patch)
tree3be9da541a34cd7e9f8211e0f18a68ede1d54c91 /src/CMakeLists.txt
parentc018204aaf4efddb5a5c1e71fe0790646cb77297 (diff)
build: add vapi scripts to VPP_HOST_TOOLS_ONLY
vapi generators were missing from the VPP_HOST_TOOLS_ONLY, which prevents building an out-of-tree plugin with API files. We now install them. Type: improvement Signed-off-by: Guillaume Solignac <gsoligna@cisco.com> Change-Id: Ie613c8f64034e933124325242f2f8b3ac3955878
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4ef4259d8f6..ee2882b4285 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -220,6 +220,14 @@ include(cmake/plugin.cmake)
option(VPP_HOST_TOOLS_ONLY "Build only host tools" OFF)
if(VPP_HOST_TOOLS_ONLY)
set(SUBDIRS tools/vppapigen cmake)
+ install(
+ PROGRAMS
+ vpp-api/vapi/vapi_c_gen.py
+ vpp-api/vapi/vapi_cpp_gen.py
+ vpp-api/vapi/vapi_json_parser.py
+ DESTINATION ${VPP_RUNTIME_DIR}
+ COMPONENT vpp-dev
+ )
elseif("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
find_package(OpenSSL)
set(SUBDIRS