aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorPing Yu <ping.yu@intel.com>2018-05-30 18:16:08 -0400
committerFlorin Coras <florin.coras@gmail.com>2018-06-15 01:30:23 +0000
commite43832c7e77b8b008ab452386b143bb3f7f5be40 (patch)
treec0cee763c6e2bdaaa758d15bf9a2638e4cbd1ea2 /src/configure.ac
parentd465631c3c97b4eb387b4b2dd851e301dc09e007 (diff)
TLS async support
Change-Id: I26194e00dfb85e5cd1c65ff4e6ffd665be2d719b Signed-off-by: Ping Yu <ping.yu@intel.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index ad2dab1e7a3..428e15d3f45 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -395,7 +395,13 @@ AM_COND_IF([ENABLE_TLSMBEDTLS_PLUGIN],
], [])
])
-AM_COND_IF([WITH_LIBSSL], [],
+AM_COND_IF([WITH_LIBSSL],
+[
+ AC_CHECK_LIB([ssl -lcrypto], [SSL_set_async_callback],
+ [
+ AC_DEFINE([HAVE_OPENSSL_ASYNC], [1], [Define if new openssl interface exists])
+ ])
+],
[
AC_MSG_WARN([openssl not enabled. Disabling tlsopenssl plugin])
enable_tlsopenssl_plugin=no