aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorSachin Saxena <sachin.saxena@nxp.com>2018-05-10 16:22:09 +0530
committerDamjan Marion <dmarion.lists@gmail.com>2018-05-16 20:00:04 +0000
commitee6ddceaf54fa055ac3fc3997156f5ee0c9ca4ae (patch)
treed1762a1a160071a3d2634034a04de2b2755545dd /src/configure.ac
parent48750899d7da52a38b5e7f940c739e2b3f10f236 (diff)
Fix broken compilation for non-numa aware platforms
- The dpdk plugin always looks for libnuma library during compilation. For non-numa aware platforms compilation breaks, if third party libnuma lib is not available. - Issue is more severe with Cross Compilation scenario where one has to download and cross compile libnuma-dev package even when target platofrom is NUMA disabled. Like when cross compiling for ARM platforms, Linaro tool-chain doesn't have libnuma by default. Change-Id: Ib85b3188b787c23ba33b47e3f6123c74fd37190e Signed-off-by: Sachin Saxena <sachin.saxena@nxp.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index ca967bb0a9d..bae3fdebcfb 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -135,6 +135,7 @@ DISABLE_ARG(japi, [Disable Java API bindings])
WITHOUT_ARG(libssl, [Disable libssl])
WITHOUT_ARG(apicli, [Disable binary api CLI])
WITHOUT_ARG(mbedtls, [Disable mbedtls])
+WITHOUT_ARG(libnuma, [for non numa architectures])
AC_ARG_WITH(unix,
AC_HELP_STRING([--with-unix],[Compile unix version of clib]),
@@ -203,6 +204,7 @@ AC_SUBST(APICLI, [-DVPP_API_TEST_BUILTIN=${n_with_apicli}])
AC_DEFINE_UNQUOTED(DPDK_SHARED_LIB, [${n_enable_dpdk_shared}])
AC_DEFINE_UNQUOTED(WITH_LIBSSL, [${n_with_libssl}])
AC_DEFINE_UNQUOTED(WITH_MBEDTLS, [${n_with_mbedtls}])
+AC_DEFINE_UNQUOTED(WITH_LIBNUMA, [${n_with_libnuma}])
# Silence following noise: