aboutsummaryrefslogtreecommitdiffstats
path: root/src/pkg/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2019-01-18 13:28:22 +0100
committerDamjan Marion <dmarion@me.com>2019-01-20 16:14:24 +0000
commit4d2f86a1ebcfc952080386603354c4767d2c8825 (patch)
treed20ed373877bfbf145d3b7ed0773a0cdbfaee32e /src/pkg/CMakeLists.txt
parente67c1d8242fec255e7449fedcbdec5c66bb3f7b2 (diff)
Rework of debian packaging
Change-Id: Ifede85d3af36f3ee6c6f8f92dcf5db0ed8f1bfeb Signed-off-by: Damjan Marion <damarion@cisco.com> Signed-off-by: Dave Barach <dave@barachs.net>
Diffstat (limited to 'src/pkg/CMakeLists.txt')
-rw-r--r--src/pkg/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/pkg/CMakeLists.txt b/src/pkg/CMakeLists.txt
new file mode 100644
index 00000000000..a725e668405
--- /dev/null
+++ b/src/pkg/CMakeLists.txt
@@ -0,0 +1,43 @@
+# Copyright (c) 2019 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+get_cmake_property(VPP_COMPONENTS COMPONENTS)
+string(REPLACE ";" " " VPP_COMPONENTS "${VPP_COMPONENTS}")
+
+execute_process(
+ COMMAND date -R
+ OUTPUT_VARIABLE TIMESTAMP
+ OUTPUT_STRIP_TRAILING_WHITESPACE
+)
+
+foreach(f rules changelog)
+ configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/debian/${f}.in
+ ${CMAKE_BINARY_DIR}/debian/${f}
+ )
+endforeach()
+
+foreach(f control copyright vpp.postinst vpp.postrm vpp.postinst vpp.service)
+ file(COPY
+ ${CMAKE_CURRENT_SOURCE_DIR}/debian/${f}
+ DESTINATION ${CMAKE_BINARY_DIR}/debian
+ )
+endforeach()
+
+file(WRITE ${CMAKE_BINARY_DIR}/debian/compat "9\n")
+
+add_custom_target(package-deb
+ COMMENT "Building .deb packages..."
+ WORKING_DIRECTORY ${CMAKE_BINARY_DIR}
+ COMMAND "dpkg-buildpackage" "-us" "-uc" "-b"
+)